summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2021-10-15 11:40:19 +0900
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:39 +0200
commit51bd29f3c842731cc80bd4e7fefe0c9dd098a2e9 (patch)
treef00027244e818b7f4dbcc277cacffde7a57093eb /gnu/packages
parenteab77626777840de7bed33e459286d2737f07baf (diff)
downloadguix-patches-51bd29f3c842731cc80bd4e7fefe0c9dd098a2e9.tar
guix-patches-51bd29f3c842731cc80bd4e7fefe0c9dd098a2e9.tar.gz
gnu: python-hpack: Update to 4.0.0.
* gnu/packages/python-web.scm (python-hpack): Update to 4.0.0 [arguments]: Reactivate skipped test in 'check phase. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eec554a182..11bb834ef9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -873,7 +873,7 @@ into HTTP/2 frames.")
(define-public python-hpack
(package
(name "python-hpack")
- (version "3.0.0")
+ (version "4.0.0")
(source
(origin
;; PyPI tarball is missing some files necessary for the tests.
@@ -883,7 +883,7 @@ into HTTP/2 frames.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0w8hkz50a6lzkmgi41ryicm0mh9ca9cx29pm3s0xlpn0vs29xrmd"))))
+ (base32 "11qdayvz5a8zlzdcdm37f2z1fgnl67pz6j8xj2dz5rfa5lds29yq"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -892,10 +892,7 @@ into HTTP/2 frames.")
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "test" "-k"
- ;; This test will be fixed in the next version. See:
- ;; https://github.com/python-hyper/hpack/issues/168.
- "not test_get_by_index_out_of_range")))))))
+ (invoke "pytest" "-vv" "test")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://hyper.rtfd.org")