summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-07-08 18:56:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-09 17:02:08 +0200
commit19db14caf710b3e497bdca4361cff829d34722ae (patch)
tree8ce982ed80046023148ff9d0fa6d56933cdab3fe /gnu/packages
parent0bb78bf9502489b7dfd6a5f91f0d18bf64f7274e (diff)
downloadguix-patches-19db14caf710b3e497bdca4361cff829d34722ae.tar
guix-patches-19db14caf710b3e497bdca4361cff829d34722ae.tar.gz
gnu: Add emacs-tide.
* gnu/packges/emacs.scm (emacs-tide): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b195b2ccf9..c6c7a1df4b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4235,6 +4235,46 @@ with @code{font-lock-mode} or @code{global-font-lock-mode}), automatic
indentation and filling of comments and C preprocessor fontification.")
(license license:gpl3+)))
+(define-public emacs-tide
+ (package
+ (name "emacs-tide")
+ (version "2.8.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ananthakumaran/tide"
+ "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k0kzqiv1hfs0kqm37947snzhrsmand3i9chvm6a2r5lb8v9q47y"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)
+ ("emacs-flycheck" ,flycheck)
+ ("emacs-typescript-mode" ,emacs-typescript-mode)))
+ (home-page "https://github.com/ananthakumaran/tide")
+ (synopsis "Typescript IDE for Emacs")
+ (description
+ "Tide is an Interactive Development Environment (IDE) for Emacs which
+provides the following features:
+
+@itemize
+@item ElDoc
+@item Auto complete
+@item Flycheck
+@item Jump to definition, Jump to type definition
+@item Find occurrences
+@item Rename symbol
+@item Imenu
+@item Compile On Save
+@item Highlight Identifiers
+@item Code Fixes
+@item Code Refactor
+@item Organize Imports
+@end itemize")
+ (license license:gpl3+)))
+
(define-public emacs-markdown-mode
(package
(name "emacs-markdown-mode")