summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2021-10-15 11:40:25 +0900
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:41 +0200
commit10beb47ca90ef34bb16a957198508b8a96520f35 (patch)
tree8ca9baae766539121133792eaacbc06a66a22e08 /gnu/packages
parente279cd5bffe9f27ef6db45656c7456c24215fc8a (diff)
downloadguix-patches-10beb47ca90ef34bb16a957198508b8a96520f35.tar
guix-patches-10beb47ca90ef34bb16a957198508b8a96520f35.tar.gz
gnu: python-unpaddedbase64: Update to 2.1.0.
* gnu/packages/python-xyz.scm (python-unpaddedbase64): Update to 2.1.0. [source]: Fetch from PyPi. [arguments]: Replace 'check phase to run tests fetched upstream from GitHub. [native-inputs]: Add `python-pytest` and `tests` for fetching upstream tests. [home-page]: Update to GitHub project home. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 30 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 47ccd74c36..2cba86b6ee 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24690,19 +24690,40 @@ replacement for dictionaries where immutability is desired.")
(define-public python-unpaddedbase64
(package
(name "python-unpaddedbase64")
- (version "1.1.0")
+ (version "2.1.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/matrix-org/python-unpaddedbase64")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "unpaddedbase64" version))
(sha256
- (base32
- "0if3fjfxga0bwdq47v77fs9hrcqpmwdxry2i2a7pdqsp95258nxd"))))
+ (base32 "01ghlmw63fgslwj8j74vkpf1kqvr7a4agm6nyn89vqwx106ccwvj"))))
(build-system python-build-system)
- (home-page "https://pypi.org/project/unpaddedbase64/")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (when tests?
+ (copy-recursively (string-append
+ (assoc-ref inputs "tests") "/tests")
+ "tests")
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("tests"
+ ;; The release on pypi comes without tests. We can't build from this
+ ;; checkout, though, because installation requires an invocation of
+ ;; poetry.
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/matrix-org/python-unpaddedbase64")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n6har8pxv0mqb96lanzihp1xf76aa17jw3977drb1fgz947pnmz"))))))
+ (home-page "https://github.com/matrix-org/python-unpaddedbase64")
(synopsis "Encode and decode Base64 without “=” padding")
(description
"RFC 4648 specifies that Base64 should be padded to a multiple of 4 bytes