summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-30 11:25:29 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-30 12:14:32 +0200
commit30dc88d975c60c6b7ca886d131d3fed1dacbad9f (patch)
tree116db3f7613000039b8c48baf54e9c62c23f7cdf /gnu/packages
parent20c05ea94af8f55821ffe203d9f0d97ab0e0748f (diff)
downloadguix-patches-30dc88d975c60c6b7ca886d131d3fed1dacbad9f.tar
guix-patches-30dc88d975c60c6b7ca886d131d3fed1dacbad9f.tar.gz
gnu: Add libchamplain.
* gnu/packages/gnome.scm (libchamplain): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f874414582..3fd2e53e23 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2720,6 +2720,38 @@ implements the ClutterGstPlayer interface using playbin. Clutter is an Open
GL based interactive canvas library.")
(license license:lgpl2.0+)))
+(define-public libchamplain
+ (package
+ (name "libchamplain")
+ (version "0.12.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/libchamplain/0.12/libchamplain-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "019b8scnx7d3wdylmpk9ihzh06w25b63x9cn8nhj6kjx82rcwlxz"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("libsoup" ,libsoup)
+ ("sqlite" ,sqlite)
+ ("clutter" ,clutter)
+ ("clutter-gtk" ,clutter-gtk)
+ ("glib:bin" ,glib "bin") ;glib-mkenums, etc.
+ ("cairo" ,cairo)
+ ("gtk+3" ,gtk+)
+ ("glib" ,glib)))
+ (home-page "http://projects.gnome.org/libchamplain/")
+ (synopsis "C library providing a ClutterActor to display maps")
+ (description
+ "libchamplain is a C library providing a ClutterActor to display maps.
+It also provides a Gtk+ widget to display maps in Gtk+ applications. Python
+and Perl bindings are also available. It supports numerous free map sources
+such as OpenStreetMap, OpenCycleMap, OpenAerialMap, and Maps for free.")
+ (license license:lgpl2.1+)))
+
(define-public gom
(package
(name "gom")