summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-02-14 14:27:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-15 17:18:54 +0100
commit3082de04c2b193bf2db2312c9ea28c18bb28bdf4 (patch)
tree1040d18f0c0c9b6b0ec7b6fe703729b72b6ead22 /gnu/packages
parent05f7296012b8a4bd6429abcaf6ff5000033a44c1 (diff)
downloadguix-patches-3082de04c2b193bf2db2312c9ea28c18bb28bdf4.tar
guix-patches-3082de04c2b193bf2db2312c9ea28c18bb28bdf4.tar.gz
gnu: Add r-dropbead.
* gnu/packages/bioinformatics.scm (r-dropbead): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 548b045599..0206eb35b5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10658,6 +10658,35 @@ are optimized per data type and for subsetted calculations such that both
memory usage and processing time is minimized.")
(license license:expat)))
+(define-public r-dropbead
+ (let ((commit "cf0be5ae5302684bd03e78ab65b142900bbbb840")
+ (revision "1"))
+ (package
+ (name "r-dropbead")
+ (version (string-append "0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rajewsky-lab/dropbead.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1b2lphsc236s1rdzlijxg8yl1jnqpwcvj4x938r89rqpj93jb780"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gplots" ,r-gplots)
+ ("r-plyr" ,r-plyr)))
+ (home-page "https://github.com/rajewsky-lab/dropbead")
+ (synopsis "Basic exploration and analysis of Drop-seq data")
+ (description "This package offers a quick and straight-forward way to
+explore and perform basic analysis of single cell sequencing data coming from
+droplet sequencing. It has been particularly tailored for Drop-seq.")
+ (license license:gpl3))))
+
(define htslib-for-sambamba
(let ((commit "2f3c3ea7b301f9b45737a793c0b2dcf0240e5ee5"))
(package