summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-06-14 23:14:13 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-15 15:27:48 +0200
commitd3a858cb32b68bf2e2ebb97c67dfca97ab59690d (patch)
treeea28617ca929778d2f614c1fa1a5d1eac955397e /gnu/packages
parent1ec32f4a9d35f235a9947f288370af1445f8ab8b (diff)
downloadguix-patches-d3a858cb32b68bf2e2ebb97c67dfca97ab59690d.tar
guix-patches-d3a858cb32b68bf2e2ebb97c67dfca97ab59690d.tar.gz
gnu: Add teensy-loader-cli.
* gnu/packages/flashing-tools.scm (teensy-loader-cli): New variable. * gnu/packages/patches/teensy-loader-cli-help.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/flashing-tools.scm51
-rw-r--r--gnu/packages/patches/teensy-loader-cli-help.patch33
2 files changed, 84 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 37a10726e3..0ab8bc57ee 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -160,3 +160,54 @@ With dfu-util you are able to download firmware to your device or upload
firmware from it.")
(home-page "http://dfu-util.sourceforge.net/")
(license gpl2+)))
+
+(define-public teensy-loader-cli
+ ;; The repo does not tag versions nor does it use releases, but a commit
+ ;; message says "Importing 2.1", while the sourcce still says "2.0". So pin
+ ;; to a fixed commit.
+ (let ((commit "f289b7a2e5627464044249f0e5742830e052e360"))
+ (package
+ (name "teensy-loader-cli")
+ (version (string-append "2.1-1." (string-take commit 7)))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/PaulStoffregen/"
+ "teensy_loader_cli/archive/" commit ".tar.gz"))
+ (sha256 (base32 "17wqc2q4fa473cy7f5m2yiyb9nq0qw7xal2kzrxzaikgm9rabsw8"))
+ (file-name (string-append "teensy-loader-cli-" version ".tar.gz" ))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ ;; Remove example flash files and teensy rebooter flash binaries.
+ (for-each delete-file (find-files "." "\\.(elf|hex)$"))
+ ;; Fix the version
+ (substitute* "teensy_loader_cli.c"
+ (("Teensy Loader, Command Line, Version 2.0\\\\n")
+ (string-append "Teensy Loader, Command Line, " ,version "\\n")))
+ #t))
+ (patches (search-patches "teensy-loader-cli-help.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; Makefile has no test target
+ #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "teensy_loader_cli" bin)
+ #t))))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)))
+ (synopsis "Command line firmware uploader for Teensy development boards")
+ (description
+ "The Teensy loader program communicates with your Teensy board when the
+HalfKay bootloader is running, so you can upload new programs and run them.
+
+You need to add the udev rules to make the Teensy update available for
+non-root users.")
+ (home-page "https://www.pjrc.com/teensy/loader_cli.html")
+ (license gpl3))))
diff --git a/gnu/packages/patches/teensy-loader-cli-help.patch b/gnu/packages/patches/teensy-loader-cli-help.patch
new file mode 100644
index 0000000000..8b3fda128a
--- /dev/null
+++ b/gnu/packages/patches/teensy-loader-cli-help.patch
@@ -0,0 +1,33 @@
+Add support for '-h' (help).
+
+https://github.com/PaulStoffregen/teensy_loader_cli/pull/26
+
+---
+ teensy_loader_cli.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/teensy_loader_cli.c b/teensy_loader_cli.c
+index d4a6cc5..0a06209 100644
+--- a/teensy_loader_cli.c
++++ b/teensy_loader_cli.c
+@@ -37,7 +37,8 @@ void usage(const char *err)
+ {
+ if(err != NULL) fprintf(stderr, "%s\n\n", err);
+ fprintf(stderr,
+- "Usage: teensy_loader_cli --mcu=<MCU> [-w] [-h] [-n] [-b] [-v] <file.hex>\n"
++ "Usage: teensy_loader_cli --mcu=<MCU> [-h] [-w] [-n] [-b] [-v] <file.hex>\n"
++ "\t-h : Print this help message\n"
+ "\t-w : Wait for device to appear\n"
+ "\t-r : Use hard reboot if device not online\n"
+ "\t-s : Use soft reboot if device not online (Teensy3.x only)\n"
+@@ -1081,6 +1082,7 @@ void parse_flag(char *arg)
+ int i;
+ for(i=1; arg[i]; i++) {
+ switch(arg[i]) {
++ case 'h': usage(NULL); break;
+ case 'w': wait_for_device_to_appear = 1; break;
+ case 'r': hard_reboot_device = 1; break;
+ case 's': soft_reboot_device = 1; break;
+--
+2.7.4
+