summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-08 17:34:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-08 17:34:35 +0100
commite5c17b8d9d3489ff8c0b03b6ffbf7ce4f9f323d0 (patch)
treeb9849ca59b73afa1fe2af04aac3f25a475eb879b /gnu/packages
parent018cf270a3f59d3f060d78719fdf1ffab1bea559 (diff)
downloadguix-patches-e5c17b8d9d3489ff8c0b03b6ffbf7ce4f9f323d0.tar
guix-patches-e5c17b8d9d3489ff8c0b03b6ffbf7ce4f9f323d0.tar.gz
gnu: Add r-vcd.
* gnu/packages/cran.scm (r-vcd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f69fbfb1a3..8121e0335f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1547,3 +1547,29 @@ where possible.")
on social exclusion and poverty, as well as an implementation of Pareto tail
modeling for empirical income distributions.")
(license license:gpl2+)))
+
+(define-public r-vcd
+ (package
+ (name "r-vcd")
+ (version "1.4-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "vcd" version))
+ (sha256
+ (base32
+ "05azric2w8mrsdk7y0484cjygcgcmbp96q2v500wvn91fj98kkhp"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-colorspace" ,r-colorspace)
+ ("r-lmtest" ,r-lmtest)
+ ("r-mass" ,r-mass)))
+ (home-page "http://cran.r-project.org/web/packages/vcd/")
+ (synopsis "Visualizing categorical data")
+ (description "This package provides visualization techniques, data sets,
+summary and inference procedures aimed particularly at categorical data.
+Special emphasis is given to highly extensible grid graphics. The package was
+originally inspired by the book \"Visualizing Categorical Data\" by Michael
+Friendly and is now the main support package for a new book, \"Discrete Data
+Analysis with R\" by Michael Friendly and David Meyer (2015).")
+ (license license:gpl2)))