summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-09-05 21:36:57 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-14 11:50:59 +0200
commitf16e6b505d5d2630b786a0477ec73b42e77b04e4 (patch)
treebcd4f4d28533e27531305a3035abe775c14a7408 /gnu/packages
parent08c7e7df156e3e61d20fba8a76bea65e1c698ef5 (diff)
downloadguix-patches-f16e6b505d5d2630b786a0477ec73b42e77b04e4.tar
guix-patches-f16e6b505d5d2630b786a0477ec73b42e77b04e4.tar.gz
gnu: Add usbip-utils
* gnu/packages/linux.scm (usbip-utils): New variable. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5a9e83238e..84846f2933 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2156,6 +2156,37 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
"Tools for working with USB devices, such as lsusb.")
(license license:gpl2+)))
+(define-public usbip-utils
+ (package
+ (name "usbip-utils")
+ (version (package-version linux-libre))
+ (source (package-source linux-libre))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "tools/usb/usbip")
+ #t)))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)
+ ("libtool" ,libtool)))
+ (inputs `(("eudev" ,eudev)))
+ (home-page (package-home-page linux-libre))
+ (synopsis "Utilities for sharing USB devices over IP networks")
+ (description
+ "The USB/IP protocol enables to pass USB device from a server to
+a client over the network. The server is a machine which shares an
+USB device and the client is a machine which uses USB device provided by
+a server over the network. The USB device may be either physical device
+connected to a server or software entity created on a server using USB
+gadget subsystem. The usbip-utils are userspace tools to used to handle
+connection and management on both side. The client needs the @file{vhci-hcd}
+Linux kernel module and the server needs the @file{usbip_host} Linux kernel
+module.")
+ (license license:gpl2)))
+
(define-public e2fsprogs
(package
(name "e2fsprogs")