summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:20:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:14:34 +0100
commitfbf38b098567cb2291fb5d8a83cda6278d9fa966 (patch)
tree308d9f3acbaaf3fa2cf247b5bf8a68dddb1195b5 /gnu/packages
parent9dc7dcb26129c182ba564d886ea43a651fd176a2 (diff)
downloadguix-patches-fbf38b098567cb2291fb5d8a83cda6278d9fa966.tar
guix-patches-fbf38b098567cb2291fb5d8a83cda6278d9fa966.tar.gz
gnu: Add ocaml-fpath.
* gnu/packages/ocaml.scm (ocaml-fpath): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c17aaf8e3f..e3aaed9b42 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1474,3 +1474,30 @@ locks or other synchronization primitives.")
performed on sources whose reporting level can be set independently. Log
message report is decoupled from logging and is handled by a reporter.")
(license license:isc)))
+
+(define-public ocaml-fpath
+ (package
+ (name "ocaml-fpath")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/fpath/releases/"
+ "fpath-" version ".tbz"))
+ (sha256
+ (base32
+ "05134ij27xjl6gaqsc65yl19vfj6cjxq3mbm9bf4mija8grdpn6g"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:build-flags (list "build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs `(("opam" ,opam)))
+ (propagated-inputs `(("topkg" ,ocaml-topkg)
+ ("astring" ,ocaml-astring)))
+ (home-page "http://erratique.ch/software/fpath")
+ (synopsis "File system paths for OCaml")
+ (description "Fpath is an OCaml module for handling file system paths with
+POSIX or Windows conventions. Fpath processes paths without accessing the
+file system and is independent from any system library.")
+ (license license:isc)))