summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:22:48 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:20:13 +0100
commit6e9b678efe7f96e8087da1aab9619e708e4e3dba (patch)
treea59b673be8195788ebe780c518e5df073d9c9ea7 /gnu/packages
parent036b85797815a86f1434072fc6a5799a2c2441af (diff)
downloadguix-patches-6e9b678efe7f96e8087da1aab9619e708e4e3dba.tar
guix-patches-6e9b678efe7f96e8087da1aab9619e708e4e3dba.tar.gz
gnu: Add ocaml-ulex.
* gnu/packages/ocaml.scm (ocaml-ulex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 489190c7df..5488308ede 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1560,3 +1560,29 @@ run command line programs.")
format. It can process XML documents without a complete in-memory
representation of the data.")
(license license:isc)))
+
+(define-public ocaml-ulex
+ (package
+ (name "ocaml-ulex")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.cduce.org/download/ulex-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fjlkwps14adfgxdrbb4yg65fhyimplvjjs1xqj5np197cig67x0"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:phases (modify-phases %standard-phases (delete 'configure))
+ #:tests? #f
+ #:make-flags
+ (list "all.opt"
+ (string-append "OCAMLBUILD=ocamlbuild -byte-plugin "
+ "-cflags -I,"
+ (assoc-ref %build-inputs "camlp4")
+ "/lib/ocaml/site-lib/camlp4"))))
+ (native-inputs `(("camlp4" ,camlp4)))
+ (home-page "http://www.cduce.org/download.html#side")
+ (synopsis "Lexer generator for Unicode and OCaml")
+ (description "Lexer generator for Unicode and OCaml.")
+ (license license:expat)))