summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:20:53 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:14:38 +0100
commit33e0702d8ac8b1bf77e48c974696779a1451f739 (patch)
tree576923d1454383355c22bc4f3a3b0eebdfd54d9d /gnu/packages
parentfbf38b098567cb2291fb5d8a83cda6278d9fa966 (diff)
downloadguix-patches-33e0702d8ac8b1bf77e48c974696779a1451f739.tar
guix-patches-33e0702d8ac8b1bf77e48c974696779a1451f739.tar.gz
gnu: Add ocaml-bos.
* gnu/packages/ocaml.scm (ocaml-bos): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e3aaed9b42..c721437322 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1501,3 +1501,35 @@ message report is decoupled from logging and is handled by a reporter.")
POSIX or Windows conventions. Fpath processes paths without accessing the
file system and is independent from any system library.")
(license license:isc)))
+
+(define-public ocaml-bos
+ (package
+ (name "ocaml-bos")
+ (version "0.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/bos/releases/"
+ "bos-" version ".tbz"))
+ (sha256
+ (base32
+ "1ly66lysk4w6mdy4k1n3ynlpfpq7lw4wshcpzgx58v6x613w5s7q"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:build-flags (list "build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs `(("opam" ,opam)))
+ (propagated-inputs `(("topkg" ,ocaml-topkg)
+ ("astring" ,ocaml-astring)
+ ("fmt" ,ocaml-fmt)
+ ("fpath" ,ocaml-fpath)
+ ("logs" ,ocaml-logs)
+ ("rresult" ,ocaml-rresult)))
+ (home-page "http://erratique.ch/software/bos")
+ (synopsis "Basic OS interaction for OCaml")
+ (description "Bos provides support for basic and robust interaction with
+the operating system in OCaml. It has functions to access the process
+environment, parse command line arguments, interact with the file system and
+run command line programs.")
+ (license license:isc)))