summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-16 11:59:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-17 21:46:48 +0100
commit26a281ef27efc9011fbe7cd42a4c0be82e013fcb (patch)
treea2b46b94ac8b30b30a21590971f2565d42ad8152 /gnu/packages
parent769fc6bb18d311bafa47e9666d35db2cb594e8ab (diff)
downloadguix-patches-26a281ef27efc9011fbe7cd42a4c0be82e013fcb.tar
guix-patches-26a281ef27efc9011fbe7cd42a4c0be82e013fcb.tar.gz
gnu: Add r-compquadform.
* gnu/packages/statistics.scm (r-compquadform): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8bbce3896d..8f72117443 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Vicente Vera Parra <vicentemvp@gmail.com>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -4031,3 +4031,24 @@ dispersion modeling and Tweedie power-law families.")
(description "This R package provides access to the code and data sets
published by the statistics blog FiveThirtyEight.")
(license license:expat)))
+
+(define-public r-compquadform
+ (package
+ (name "r-compquadform")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "CompQuadForm" version))
+ (sha256
+ (base32
+ "0bsgbdblxpv57mbwnf51xyiydp2bqyxkg4zzwqki85cv5xqlrq1n"))))
+ (properties `((upstream-name . "CompQuadForm")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/CompQuadForm")
+ (synopsis "Distribution function of quadratic forms in normal variables")
+ (description
+ "This package provides functions to compute the distribution function of
+quadratic forms in normal variables using Imhof's method, Davies's algorithm,
+Farebrother's algorithm or Liu et al.'s algorithm.")
+ (license license:gpl2+)))