summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:21:52 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:14:42 +0100
commit036b85797815a86f1434072fc6a5799a2c2441af (patch)
tree45ed003e631078946c9eb4c5a86d422169a1b29e /gnu/packages
parent33e0702d8ac8b1bf77e48c974696779a1451f739 (diff)
downloadguix-patches-036b85797815a86f1434072fc6a5799a2c2441af.tar
guix-patches-036b85797815a86f1434072fc6a5799a2c2441af.tar.gz
gnu: Add ocaml-xmlm.
* gnu/packages/ocaml.scm (ocaml-xmlm): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c721437322..489190c7df 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1533,3 +1533,30 @@ the operating system in OCaml. It has functions to access the process
environment, parse command line arguments, interact with the file system and
run command line programs.")
(license license:isc)))
+
+(define-public ocaml-xmlm
+ (package
+ (name "ocaml-xmlm")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/xmlm/releases/"
+ "xmlm-" version ".tbz"))
+ (sha256
+ (base32
+ "1jywcrwn5z3gkgvicr004cxmdaqfmq8wh72f81jqz56iyn5024nh"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key #:allow-other-keys)
+ (zero? (system* "pkg/build" "true")))))))
+ (native-inputs `(("opam" ,opam)))
+ (home-page "http://erratique.ch/software/xmlm")
+ (synopsis "Streaming XML codec for OCaml")
+ (description "Xmlm is a streaming codec to decode and encode the XML data
+format. It can process XML documents without a complete in-memory
+representation of the data.")
+ (license license:isc)))