summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2016-12-23 14:56:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-24 14:41:50 +0100
commitdb8255701314748c3a1199401b04a65e10866784 (patch)
treed3040dc2ebb33b0d25d7b3c46bd93e9fe0aa6935 /gnu/packages
parentf7fb34a06cea1745f1a2591b0c8135e6a86947e3 (diff)
downloadguix-patches-db8255701314748c3a1199401b04a65e10866784.tar
guix-patches-db8255701314748c3a1199401b04a65e10866784.tar.gz
gnu: netcdf: Enable HDF4 support.
* gnu/packages/maths.scm (netcdf)[inputs]: Add hdf4-alt and libjpeg. [arguments]: Add "--enable-hdf4" configure flag. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e15eddc366..d045895d5d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -726,10 +726,12 @@ HDF5 file is encoded according to the HDF File Format Specification.")
("doxygen" ,doxygen)
("graphviz" ,graphviz)))
(inputs
- `(("hdf5" ,hdf5)
- ("zlib" ,zlib)))
+ `(("hdf4" ,hdf4-alt)
+ ("hdf5" ,hdf5)
+ ("zlib" ,zlib)
+ ("libjpeg" ,libjpeg)))
(arguments
- `(#:configure-flags '("--enable-doxygen" "--enable-dot")
+ `(#:configure-flags '("--enable-doxygen" "--enable-dot" "--enable-hdf4")
#:parallel-tests? #f)) ;various race conditions
(home-page "http://www.unidata.ucar.edu/software/netcdf/")
(synopsis "Library for scientific data")