summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-26 16:35:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-26 16:40:42 +0100
commit24d64989729b264ea0d8cd42149ec23b12229632 (patch)
tree0278d75684006e3e44c5f6fd57f9a9a5ffba8841 /gnu/packages
parent6994e6743603ab73cc32d32786a55672f4fa46f0 (diff)
downloadguix-patches-24d64989729b264ea0d8cd42149ec23b12229632.tar
guix-patches-24d64989729b264ea0d8cd42149ec23b12229632.tar.gz
gnu: python-xopen: Update to 0.5.0.
* gnu/packages/python-xyz.scm (python-xopen): Update to 0.5.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78453b2974..8a6c409ae4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10836,16 +10836,17 @@ network.")
(define-public python-xopen
(package
(name "python-xopen")
- (version "0.3.3")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xopen" version))
(sha256
(base32
- "1a0wbil552wsmklwd89ssmgz3pjd86qa9i7jh8wqb9wslc8a2qjr"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "17xbrgi23l87yg6h0qcknssp2q812miiy33qw6v45v5gx0jwv5xh"))))
(build-system python-build-system)
+ (propagated-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "https://github.com/marcelm/xopen/")
(synopsis "Open compressed files transparently")
(description "This module provides an @code{xopen} function that works like