summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 14:41:37 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:09 +0000
commit1485d531a734cb26be7a8da495a01c2499854fcc (patch)
treec952467de9194029d1bb91658a476b4b89bc6734 /gnu/packages
parent2505055c02163c83d43c86792676dc39935b7f3d (diff)
downloadguix-patches-1485d531a734cb26be7a8da495a01c2499854fcc.tar
guix-patches-1485d531a734cb26be7a8da495a01c2499854fcc.tar.gz
gnu: libxi: Add --disable-malloc0-returnsnull when necessary.
* gnu/packages/xorg.scm (libxi)[arguments]<#:configure-flags>: Add malloc0-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xorg.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index aedaa1b498..23ebce17ff 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5207,10 +5207,11 @@ new API's in libXft, or the legacy API's in libX11.")
(build-system gnu-build-system)
(outputs '("out" "doc")) ;man pages represent 28% of the total
(arguments
- '(#:configure-flags (list "--disable-static"
+ `(#:configure-flags (list "--disable-static"
(string-append "--mandir="
(assoc-ref %outputs "doc")
- "/share/man"))))
+ "/share/man")
+ ,@(malloc0-flags))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libx11" ,libx11)