summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-08-06 11:45:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-13 15:53:29 +0200
commit90b4abe36e4f842f5137e7be47565ad5fed1e534 (patch)
tree438e73a32323fa33dc9705802b8a32e98d419848 /gnu/packages
parent776346fcdad5135769a47fb0e922d8b31c6a2d22 (diff)
downloadguix-patches-90b4abe36e4f842f5137e7be47565ad5fed1e534.tar
guix-patches-90b4abe36e4f842f5137e7be47565ad5fed1e534.tar.gz
gnu: Add emacs-epithet.
* gnu/packages/emacs-xyz.scm (emacs-epithet): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3fea334e3b..2145668262 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10244,6 +10244,32 @@ provide the historic behavior of @code{flet}, as well as
@code{declare-function} stub for older Emacs.")
(license license:gpl2+)))
+(define-public emacs-epithet
+ ;; No tags.
+ (let ((commit "cc42338376c2c58da561214c554be8e8856f6a2b"))
+ (package
+ (name "emacs-epithet")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/epithet")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06irgshgcgmm09nswrny8mam6l660ai71rgn0l3rmyp9li8n97j0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/oantolin/epithet")
+ (synopsis "Rename Emacs buffers with descriptive names")
+ (description
+ "This package provides a function---@code{epithet-rename-buffer}---to rename
+the current buffer with a descriptive name. The name suggestion is governed by
+the @code{epithet-suggesters} hook variable: each hook should return either a
+name suggestion or @code{nil}, they are called in turn and the first non-nil
+suggestion is taken.")
+ (license license:gpl3+))))
+
(define-public emacs-mocker
(package
(name "emacs-mocker")