summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-05-04 22:28:33 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-04 22:28:33 +0100
commitd6ed49ba3fbcb6ae522acb3757f93ca8da01648f (patch)
tree619b30c395f5c49afc143a7edbf8bfaeeaa8838f /gnu/packages
parente5d57c1c0b068e0c9664a8e209adf415e9cc4174 (diff)
downloadguix-patches-d6ed49ba3fbcb6ae522acb3757f93ca8da01648f.tar
guix-patches-d6ed49ba3fbcb6ae522acb3757f93ca8da01648f.tar.gz
gnu: python-qrcode: Use a newer version of setuptools.
The upgrade from 5.3 to 6.0 switches to rely on the on the setup.cfg, and with the version of setuptools incldued with Python, this isn't supported, so no actual code is installed, and the output is mostly empty. * gnu/packages/python.scm (python-qrcode)[inputs]: Add python-setuptools.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a359eebd12..f63460b8ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10414,6 +10414,10 @@ a file-like object from which an arbitrarly-sized key can be read.")
`(("python-lxml" ,python-lxml) ; for SVG output
("python-pillow" ,python-pillow) ; for PNG output
("python-six" ,python-six)))
+ (inputs
+ `(;; The setup.cfg file needs to be used, and support for this requires
+ ;; at least version 30.3.0 of setuptools
+ ("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/lincolnloop/python-qrcode")
(synopsis "QR Code image generator")
(description "This package provides a pure Python QR Code generator