summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-01 16:12:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-03 23:04:40 -0400
commitb9a7fa817a65f74a68c5a5104d9ec861fb778800 (patch)
treee996d9fdeda9f65d107386a08fd080161627bd9a /gnu/packages
parented660956792c4212bdc83f65f83aa11882178595 (diff)
downloadguix-patches-b9a7fa817a65f74a68c5a5104d9ec861fb778800.tar
guix-patches-b9a7fa817a65f74a68c5a5104d9ec861fb778800.tar.gz
gnu: linux-libre: Use Python 3 in make-linux-libre-source.
Successfully tested with all of the linux-libre versions we carry in Guix: 4.4.234, 4.9.234, 4.14.195, 4.19.142, 5.4.61 and 5.8.5. * gnu/packages/linux.scm (make-linux-libre-source): Replace python-2 by python-wrapper. Do not set the PYTHON environment variable, which is not required when using python-wrapper.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1d267bb659..499f5bb220 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -296,11 +296,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
#+(canonical-package bzip2)
#+(canonical-package gzip)
#+(canonical-package tar)
- ;; The comments in the 'deblob-check' script
- ;; claim that it supports Python 2 and 3, but
- ;; in fact it fails when run in Python 3 as
- ;; of version 5.1.3.
- #+python-2))
+ #+python-wrapper))
(with-directory-excursion "/tmp/bin"
@@ -337,7 +333,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(error "multiple directories found" dirs)))))
(with-directory-excursion dir
- (setenv "PYTHON" (which "python"))
(format #t "Running deblob script...~%")
(force-output)
(invoke "/tmp/bin/deblob"))