summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-07 22:50:45 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-08 00:12:30 +0200
commitac47a7c240955bd7cc23179e2cb95fed207d98ba (patch)
treed3cbf8640622d189da43d870f0c282094a0da516 /gnu/packages
parentfa40e4d4ec92222fa68cb9694812a310344cc4f0 (diff)
downloadguix-patches-ac47a7c240955bd7cc23179e2cb95fed207d98ba.tar
guix-patches-ac47a7c240955bd7cc23179e2cb95fed207d98ba.tar.gz
gnu: linux-libre: Use the GNU + Freedo boot logo.
* gnu/packages/linux.scm (%boot-logo-patch): New variable. (linux-libre)[build-phase]: Apply it. [native-inputs]: Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 841ec581d9..a6a032cd2d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -158,10 +158,24 @@
`insmod', `lsmod', and more.")
(license gpl2+)))
+(define %boot-logo-patch
+ ;; Linux-Libre boot logo featuring Freedo and a gnu.
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.fsfla.org/svn/fsfla/software/linux-libre/"
+ "lemote/gnewsense/branches/3.15/100gnu+freedo.patch"))
+ (sha256
+ (base32
+ "1hk9swxxc80bmn2zd2qr5ccrjrk28xkypwhl4z0qx4hbivj7qm06"))))
+
(define-public linux-libre
(let* ((version "3.15")
(build-phase
- '(lambda* (#:key system #:allow-other-keys #:rest args)
+ '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
+ ;; Apply the neat patch.
+ (system* "patch" "-p1" "--batch"
+ "-i" (assoc-ref inputs "patch/freedo+gnu"))
+
(let ((arch (car (string-split system #\-))))
(setenv "ARCH"
(cond ((string=? arch "i686") "i386")
@@ -226,7 +240,8 @@
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("bc" ,bc)
- ("module-init-tools" ,module-init-tools)))
+ ("module-init-tools" ,module-init-tools)
+ ("patch/freedo+gnu" ,%boot-logo-patch)))
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)