summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-11 14:39:41 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-11 14:39:41 +0200
commit7c829150ed2197359982e02f2d1dd25a2c868013 (patch)
tree978b0871426c563e0044b52e65df2ac2fd590056 /gnu/packages
parentc605aa254cc0c486192d824d943554545cdf51b8 (diff)
downloadguix-patches-7c829150ed2197359982e02f2d1dd25a2c868013.tar
guix-patches-7c829150ed2197359982e02f2d1dd25a2c868013.tar.gz
gnu: python-stem: Fix tests wth python 3.9.
* gnu/packages/python-xyz.scm (python-stem)[arguments]: Add 'fix-tests' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa3f7d24e2..506df43094 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15641,6 +15641,12 @@ documentation to argparse configuration.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ ;; See https://github.com/torproject/stem/issues/56
+ (lambda _
+ (substitute* "run_tests.py"
+ (("test\\.task\\.MOCK_VERSION,")
+ ""))))
(replace 'check
(lambda _
(invoke "./run_tests.py" "--unit")