summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-20 21:14:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 15:24:34 +0200
commit222c6b94083e63323303311c6c42b4a8c2b4f392 (patch)
treee276b97a1668900ff0575379e65856b3ff926608 /gnu/packages
parent7dff32986228fb515dbda483aaee18de93489e2a (diff)
downloadguix-patches-222c6b94083e63323303311c6c42b4a8c2b4f392.tar
guix-patches-222c6b94083e63323303311c6c42b4a8c2b4f392.tar.gz
Remove the last vestiges of GuixSD.
* gnu/build/vm.scm (load-in-linux-vm): Rename the RNG. * gnu/system/vm.scm (common-qemu-options): Likewise. (system-docker-image): Rename the ROOT-DIRECTORY. * gnu/packages/crypto.scm (eschalot)[arguments]: Use a different arbitrary string. * gnu/packages/wicd.scm (wicd)[arguments]: Remove unused configure flag. * gnu/packages/xorg.scm (xorg-server): Set a more accurate OS vendor.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/backup.scm4
-rw-r--r--gnu/packages/crypto.scm2
-rw-r--r--gnu/packages/wicd.scm5
-rw-r--r--gnu/packages/xorg.scm6
4 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9cb8e1bd00..051b200631 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -812,8 +812,8 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
(output-dir
(assoc-ref outputs "out"))
- ;; Just a default... not so useful on guixsd though
- ;; You probably want to a service with file(s) to point to.
+ ;; Just a default... not so useful on Guix Systems though.
+ ;; You probably want a service with file(s) to point to.
(confdir "/etc/dirvish")
(perl (string-append (assoc-ref %build-inputs "perl")
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 028c140185..68531ea16e 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -376,7 +376,7 @@ secure operations. ")
(lambda _
(invoke "./worgen" "8-12" "top1000.txt" "3-10" "top400nouns.txt"
"3-6" "top150adjectives.txt" "3-6")
- (invoke "./eschalot" "-r" "^guix|^guixsd")
+ (invoke "./eschalot" "-r" "^guix|^GuixSystem")
(invoke "./eschalot" "-r" "^gnu|^free")
(invoke "./eschalot" "-r" "^cyber|^hack")
(invoke "./eschalot" "-r" "^troll")))
diff --git a/gnu/packages/wicd.scm b/gnu/packages/wicd.scm
index fec39ad530..073d440479 100644
--- a/gnu/packages/wicd.scm
+++ b/gnu/packages/wicd.scm
@@ -123,7 +123,10 @@
"--no-install-kde"
"--no-install-gnome-shell-extensions"
- "--distro=guixsd"
+ ;; Don't pass --distro= despite setup.py's complaints.
+ ;; Guix isn't recognised, and if it ever would be we'd
+ ;; rather ask upstream to follow standards instead.
+
"--wicdgroup=netdev"
"--loggroup=root"
"--logperms=0640"
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 9f717ab7d7..60e80e1fda 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5400,13 +5400,11 @@ over Xlib, including:
;; The default is to use "uname -srm", which captures the kernel
;; version and makes builds non-reproducible.
"--with-os-name=GNU"
-
- "--with-os-vendor=GuixSD" ;not strictly needed, but looks nice
-
+ "--with-os-vendor=Guix" ; not strictly needed, but looks nice
;; For the log file, etc.
"--localstatedir=/var"
- ;; For sddm
+ ;; For sddm.
"--enable-kdrive"
"--enable-xephyr")