summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 09:55:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commite5ff6dc3f390c190552c7d3e71aa490dc8c5434b (patch)
tree18f3d6695cd374d3bb615f983de39334661c83fb /gnu/packages
parent0f6902ea79963a2c5d931414103de978a86f9dfd (diff)
downloadguix-patches-e5ff6dc3f390c190552c7d3e71aa490dc8c5434b.tar
guix-patches-e5ff6dc3f390c190552c7d3e71aa490dc8c5434b.tar.gz
gnu: julia-compilersupportlibraries-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-compilersupportlibraries-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-jll.scm47
-rw-r--r--gnu/packages/julia-xyz.scm45
2 files changed, 47 insertions, 45 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 1b63c06312..8b6ef39c43 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -24,8 +25,54 @@
#:use-module (guix utils)
#:use-module (guix build-system julia)
#:use-module (gnu packages)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages julia))
+;;; TODO: Remove this autogenerated source package
+;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
+
+(define-public julia-compilersupportlibraries-jll
+ (package
+ (name "julia-compilersupportlibraries-jll")
+ (version "0.4.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/CompilerSupportLibraries_jll.jl")
+ (commit (string-append "CompilerSupportLibraries-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03j6xdvps259mhdzpjqf41l65w2l9sahvxg4wrp34hcf69wkrzpy"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f ; no runtests.jl
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"CompilerSupportLibraries\", \""
+ (assoc-ref inputs "gfortran:lib") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$"))
+ #t)))))
+ (inputs ;required by artifacts
+ `(("gfortran:lib" ,gfortran "lib")))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/CompilerSupportLibraries_jll.jl")
+ (synopsis "Internal wrappers")
+ (description "This package provides compiler support for libraries. It is
+an autogenerated source package constructed using @code{BinaryBuilder.jl}. The
+originating @code{build_tarballs.jl} script can be found on the community
+build tree Yggdrasil.")
+ (license license:expat)))
+
(define-public julia-jllwrappers
(package
(name "julia-jllwrappers")
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b8ba5bf93f..35f7bd8d3f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -24,7 +24,6 @@
#:use-module (guix git-download)
#:use-module (guix build-system julia)
#:use-module (gnu packages compression)
- #:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia-jll)
@@ -405,50 +404,6 @@ provides a macro that lets you use the latest syntax in a backwards-compatible
way.")
(license license:expat)))
-;;; TODO: Remove this autogenerated source package
-;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
-(define-public julia-compilersupportlibraries-jll
- (package
- (name "julia-compilersupportlibraries-jll")
- (version "0.4.0+1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/CompilerSupportLibraries_jll.jl")
- (commit (string-append "CompilerSupportLibraries-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "03j6xdvps259mhdzpjqf41l65w2l9sahvxg4wrp34hcf69wkrzpy"))))
- (build-system julia-build-system)
- (arguments
- `(#:tests? #f ; no runtests.jl
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("generate_wrapper_header.*")
- (string-append
- "generate_wrapper_header(\"CompilerSupportLibraries\", \""
- (assoc-ref inputs "gfortran:lib") "\")\n"))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$"))
- #t)))))
- (inputs ;required by artifacts
- `(("gfortran:lib" ,gfortran "lib")))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/CompilerSupportLibraries_jll.jl")
- (synopsis "Internal wrappers")
- (description "This package provides compiler support for libraries. It is
-an autogenerated source package constructed using @code{BinaryBuilder.jl}. The
-originating @code{build_tarballs.jl} script can be found on the community
-build tree Yggdrasil.")
- (license license:expat)))
-
(define-public julia-constructionbase
(package
(name "julia-constructionbase")