summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2019-06-18 01:58:05 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-19 22:56:27 +0200
commita7a31827619b23f71160e224f6ab658cd9419662 (patch)
tree499e135e8e9730721549b169068f096f7d91f114 /gnu/packages
parentaad086d8717d8ee6fa0ec37dd7932b74fe6398c3 (diff)
downloadguix-patches-a7a31827619b23f71160e224f6ab658cd9419662.tar
guix-patches-a7a31827619b23f71160e224f6ab658cd9419662.tar.gz
gnu: Add numix-theme.
* gnu/packages/gnome.scm (numix-theme): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 875d28caee..ad6b9203b9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6880,6 +6881,38 @@ functionality and behavior.")
(home-page "https://extensions.gnome.org/")
(license license:gpl3+)))
+(define-public numix-theme
+ (package
+ (name "numix-theme")
+ (version "2.6.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/numixproject/numix-gtk-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
+ ("gnome-shell" ,gnome-shell)
+ ("gtk+" ,gtk+)
+ ("xmllint" ,libxml2)
+ ("ruby-sass" ,ruby-sass)))
+ (synopsis "Flat theme with light and dark elements")
+ (description "Numix is a modern flat theme with a combination of light and
+dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
+ (home-page "https://numixproject.github.io")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")