summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 20:09:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 20:19:05 +0300
commit6a29b83423bd36c0d82a5511395323f8c4e15a99 (patch)
tree061749ec66ac8b2526e1917b2e302e2417d3e141 /gnu/packages
parent81698e5099bee8b5b5e7d19d9db7d9d1a771912c (diff)
downloadguix-patches-6a29b83423bd36c0d82a5511395323f8c4e15a99.tar
guix-patches-6a29b83423bd36c0d82a5511395323f8c4e15a99.tar.gz
gnu: python-identify: Honor #:tests in check phase.
* gnu/packages/python-xyz.scm (python-identify)[arguments]: Honor tests?.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b160996756..5223f5a73e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20751,8 +20751,9 @@ library to allow local file system access via @code{file://} URLs.")
;; system-error "utime" "~A" ("No such file or directory")
(delete 'ensure-no-mtimes-pre-1980)
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)))