summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:26:33 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commite1c1b71c38cacecce168752a72f466506caf2b45 (patch)
treeaf5ddcf65e79bb4187095cdf271f0ecd17817c8f /gnu/packages
parent0eeaa169a0eaeafc9b65dd1686cf680765e3be5f (diff)
downloadguix-patches-e1c1b71c38cacecce168752a72f466506caf2b45.tar
guix-patches-e1c1b71c38cacecce168752a72f466506caf2b45.tar.gz
gnu: ghc-async: Enable tests.
* gnu/packages/haskell.scm (ghc-async)[arguments]: Remove. [inputs]: Add ghc-hunit, ghc-test-framework, and ghc-test-framework-hunit.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e3dc29ba39..1ef74fb8c6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3704,7 +3704,10 @@ library for Haskell.")
(base32
"0azx4qk65a9a2gvqsfmz3w89m6shzr2iz0i5lly2zvly4n2d6m6v"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
(propagated-inputs
`(("ghc-stm" ,ghc-stm)))
(home-page "https://github.com/simonmar/async")