summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-18 17:42:44 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-18 17:47:09 +0100
commita9346faee6f61d7a2b0e066b110c9ce660827dbd (patch)
tree94ee9a97bee7d5c4ac89b13dfb2f4efac4890b6b /gnu/packages
parente33cf9a69ae20d6d3098a1287d9247b1e32c7402 (diff)
downloadguix-patches-a9346faee6f61d7a2b0e066b110c9ce660827dbd.tar
guix-patches-a9346faee6f61d7a2b0e066b110c9ce660827dbd.tar.gz
gnu: weechat: Record the absolute file name of 'python'.
Fixes <http://bugs.gnu.org/21879>. Reported by Luis Felipe López Acevedo <felipe.lopez@openmailbox.org>. * gnu/packages/weechat.scm (weechat)[arguments]: Add 'set-python-file-name' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/weechat.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index 18508dd09d..c0fd8c6c88 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,7 +83,15 @@
#:phases (modify-phases %standard-phases
(add-before 'configure 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "./autogen.sh"))))
+ (add-before 'build 'set-python-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/plugins/python/weechat-python.c"
+ (("python2_bin = .*;")
+ (string-append "python2_bin = \""
+ (assoc-ref inputs "python")
+ "/bin/python\";\n")))
+ #t)))))
(synopsis "Extensible chat client")
(description "WeeChat (Wee Enhanced Environment for Chat) is an
Internet Relay Chat client, which is designed to be light and fast.