summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:17:43 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commit1fe25c573a24d6aa9a7b577c186c88ca16788129 (patch)
treeaa7164dc110642018ff9e0ab3e18659f5a5f871b /gnu/packages
parent09655c676be6ae7114ad8016e745dac315e769fe (diff)
downloadguix-patches-1fe25c573a24d6aa9a7b577c186c88ca16788129.tar
guix-patches-1fe25c573a24d6aa9a7b577c186c88ca16788129.tar.gz
gnu: Add ghc-test-framework-hunit.
* gnu/packages/haskell.scm (ghc-test-framework-hunit): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f3086b1fb7..843df52a91 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1755,6 +1755,30 @@ by command line options. All of this comes with colored test output, progress
reporting and test statistics output.")
(license bsd-3)))
+(define-public ghc-test-framework-hunit
+ (package
+ (name "ghc-test-framework-hunit")
+ (version "0.3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "test-framework-hunit/test-framework-hunit-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1h0h55kf6ff25nbfx1mhliwyknc0glwv3zi78wpzllbjbs7gvyfk"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)))
+ (home-page "https://batterseapower.github.io/test-framework/")
+ (synopsis "HUnit support for test-framework")
+ (description
+ "This package provides HUnit support for the test-framework package.")
+ (license bsd-3)))
+
(define-public ghc-tf-random
(package
(name "ghc-tf-random")