summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:46:36 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commit19206f5eb87c283d8e125f4e910b17ae25b618f7 (patch)
tree19f724a0e304505d67f6fd8fcdddb741881680b8 /gnu/packages
parentab715ec9ae8b9762662a6efbab35a2733952c9e6 (diff)
downloadguix-patches-19206f5eb87c283d8e125f4e910b17ae25b618f7.tar
guix-patches-19206f5eb87c283d8e125f4e910b17ae25b618f7.tar.gz
gnu: ghc-attoparsec: Enable tests.
* gnu/packages/haskell.scm (ghc-attoparsec)[arguments]: Remove. [inputs]: Add ghc-quickcheck, ghc-quickcheck-unicode, ghc-test-framework, and ghc-test-framework-quickcheck2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2cb25de45f..29ff5c2678 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2191,11 +2191,14 @@ with slicing and Clang-style colored diagnostics.")
(base32
"0cprkr7bl4lrr80pz8mryb4rbfwdgpsrl7g0fbcaybhl8p5hm26f"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: ghc-test-framework unavailable
(propagated-inputs
`(("ghc-scientific" ,ghc-scientific)))
(inputs
- `(("ghc-text" ,ghc-text)
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-unicode" ,ghc-quickcheck-unicode)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-text" ,ghc-text)
("ghc-vector" ,ghc-vector)))
(home-page "https://github.com/bos/attoparsec")
(synopsis "Fast combinator parsing for bytestrings and text")