summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:01:40 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commit1472ba25465df75d1d17c50e8c4db9cd71bd2343 (patch)
tree63a912564c8c7014423e02f5ff678a95f88e82c4 /gnu/packages
parentccd7b3087218d90cc29e11307755fae43aae2904 (diff)
downloadguix-patches-1472ba25465df75d1d17c50e8c4db9cd71bd2343.tar
guix-patches-1472ba25465df75d1d17c50e8c4db9cd71bd2343.tar.gz
gnu: Add ghc-libxml.
* gnu/packages/haskell.scm (ghc-libxml): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e009e0f583..2e071abcc6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages python)
#:use-module (gnu packages pcre)
+ #:use-module ((gnu packages xml) #:select (libxml2))
#:use-module (gnu packages xorg))
(define ghc-bootstrap-x86_64-7.8.4
@@ -267,6 +268,33 @@ interactive environment for the functional language Haskell.")
determine the hostname.")
(license bsd-3)))
+(define-public ghc-libxml
+ (package
+ (name "ghc-libxml")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/libxml/"
+ "libxml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01zvk86kg726lf2vnlr7dxiz7g3xwi5a4ak9gcfbwyhynkzjmsfi"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("libxml2" ,libxml2)))
+ (arguments
+ `(#:configure-flags
+ `(,(string-append "--extra-include-dirs="
+ (assoc-ref %build-inputs "libxml2")
+ "/include/libxml2"))))
+ (home-page "http://hackage.haskell.org/package/libxml")
+ (synopsis "Haskell bindings to libxml2")
+ (description
+ "This library provides minimal Haskell binding to libxml2.")
+ (license bsd-3)))
+
(define-public ghc-prelude-extras
(package
(name "ghc-prelude-extras")