summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 11:56:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:17 +0200
commitf2536af288e109b7c7eb383fd5881985d5b53f21 (patch)
tree78ab3f59e4399499adebc84b64f6d680a0d8e5bc /gnu/packages
parentc3455b7d10f5872554c6df2fd765bf7dc4c21cdb (diff)
downloadguix-patches-f2536af288e109b7c7eb383fd5881985d5b53f21.tar
guix-patches-f2536af288e109b7c7eb383fd5881985d5b53f21.tar.gz
gnu: Add texlive-latex-tools.
* gnu/packages/tex.scm (texlive-latex-tools): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7fbb14274c..623cc34b30 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1027,6 +1027,31 @@ better accessibility support for PDF files; extensible chemists reaction
arrows; record information about document class(es) used; and many more.")
(license license:lppl1.3+)))
+(define-public texlive-latex-tools
+ (package
+ (name "texlive-latex-tools")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "tools"))
+ (sha256
+ (base32
+ "052a0pch2k5zls5jlay9xxcf93rw3i60a2x28y3ip3rhbsv3xgiz"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/tools"
+ #:build-targets '("tools.ins")))
+ (home-page "http://www.ctan.org/pkg/latex-tools")
+ (synopsis "LaTeX standard tools bundle")
+ (description
+ "This package is a collection of (variously) simple tools provided as
+part of the LaTeX required tools distribution, comprising the following
+packages: afterpage, array, bm, calc, dcolumn, delarray, enumerate, fileerr,
+fontsmpl, ftnright, hhline, indentfirst, layout, longtable, multicol,
+rawfonts, showkeys, somedefs, tabularx, theorem, trace, varioref, verbatim,
+xr, and xspace.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")