summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIvan Gankevich <i.gankevich@spbu.ru>2021-07-07 10:25:51 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-09 00:22:05 +0200
commite499500730de23fd54ae63696a725d4b90a406d7 (patch)
tree2a8c4e6196cb6a7c27b2dd20f4f71a5867119084 /gnu/packages
parent889c5c584f0198e854db23bff6cad5697a56ffe7 (diff)
downloadguix-patches-e499500730de23fd54ae63696a725d4b90a406d7.tar
guix-patches-e499500730de23fd54ae63696a725d4b90a406d7.tar.gz
gnu: Add bibtool.
* gnu/packages/tex.scm (bibtool): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 086d6190dd..8afa18a7fd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8629,3 +8630,33 @@ constructs TeX accepts as arguments to its @code{\\number} primitive
are valid as arguments for the macros. The package may be used under
LaTeX and plain TeX.")
(license (license:fsf-free "file:/binhex.dtx"))))
+
+(define-public bibtool
+ (package
+ (name "bibtool")
+ (version "2.68")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ge-ne/bibtool")
+ (commit (string-append
+ "BibTool_"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c))
+ version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0grnmqj8w5018nd7r6drnq2yvfhf22gj9i3rj8ilhzm7zmz3zn0g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"))
+ (native-inputs
+ `(("perl" ,perl)))
+ (home-page "http://www.gerd-neugebauer.de/software/TeX/BibTool/en")
+ (synopsis "Tool for manipulating BibTeX databases")
+ (description
+ "BibTool manipulates BibTeX files. The possibilities of BibTool include
+sorting and merging of BibTeX databases, generation of uniform reference keys,
+and selecting references used in a publication.")
+ (license license:gpl2+)))