summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:23:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:21 +0200
commitc6849d2ca25ccb610115bad2e02181b3d7c433c7 (patch)
treea87aacf1b4cb94cc65196c518f620578c304e5ca /gnu/packages
parentb28cfb83e4d9c314969b5f6772041b8e8a3c2e64 (diff)
downloadguix-patches-c6849d2ca25ccb610115bad2e02181b3d7c433c7.tar
guix-patches-c6849d2ca25ccb610115bad2e02181b3d7c433c7.tar.gz
gnu: Add r-paws-storage.
* gnu/packages/cran.scm (r-paws-storage): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9946d779b6..d4e0da0e91 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30838,3 +30838,25 @@ CloudFront content delivery, load balancing, and more.")
services, including Relational Database Service (RDS), DynamoDB NoSQL
database, and more.")
(license license:asl2.0)))
+
+(define-public r-paws-storage
+ (package
+ (name "r-paws-storage")
+ (version "0.1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "paws.storage" version))
+ (sha256
+ (base32
+ "06m887vpqp5d6k3zxdlga599dsv8v3rladk7xqaxqnld1f17am04"))))
+ (properties `((upstream-name . "paws.storage")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-paws-common" ,r-paws-common)))
+ (home-page "https://github.com/paws-r/paws")
+ (synopsis "Amazon Web Services storage services")
+ (description
+ "This package provides an interface to Amazon Web Services storage
+services, including Simple Storage Service (S3).")
+ (license license:asl2.0)))