summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 15:23:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:02 +0100
commitb41a05ce497d5ecc682cf46ce61aa2215193f9f6 (patch)
treedf76eaccd4a00fd741a66394a2bcf73e18dd7680 /gnu/packages
parentd8013ee221bd599474340899ffb5974796091955 (diff)
downloadguix-patches-b41a05ce497d5ecc682cf46ce61aa2215193f9f6.tar
guix-patches-b41a05ce497d5ecc682cf46ce61aa2215193f9f6.tar.gz
gnu: Remove work-arounds for bug 20765 (ensure uncompressed eggs).
Bug 20765 is solved since we build all Python packages using option "--single-version-externally-managed". * gnu/packages/bioinformatics.scm (pbtranscript-tofu): Remove configure-flags. (pepr): remove phase "disable-egg-generation". * gnu/packages/pdf.scm (reportlab): Remove configure-flags. * gnu/packages/python.scm (python-sphinx-rtd-theme, python2-elib.intl, python-pkgconfig, python-pytest-pep8, python-pytest-flakes): Remove configure-flags. (python-pillow) remove phase "disable-egg-generation". (python-libarchive-c) Remove patching setup.cfg. * gnu/packages/statistics.scm (python-patsy): remove phase "prevent-generation-of-egg-archive". * gnu/packages/tls.scm (python-acme): remove phase "disable-egg-compression". * gnu/packages/tor.scm (onionshare): Remove configure-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm19
-rw-r--r--gnu/packages/pdf.scm5
-rw-r--r--gnu/packages/python.scm47
-rw-r--r--gnu/packages/statistics.scm8
-rw-r--r--gnu/packages/tls.scm9
-rw-r--r--gnu/packages/tor.scm6
6 files changed, 7 insertions, 87 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 481a2a3bcb..9872933693 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3563,11 +3563,6 @@ the phenotype as it models the data.")
(build-system python-build-system)
(arguments
`(#:python ,python-2
- ;; With standard flags, the install phase attempts to create a zip'd
- ;; egg file, and fails with an error: 'ZIP does not support timestamps
- ;; before 1980'
- #:configure-flags '("--single-version-externally-managed"
- "--record=pbtranscript-tofu.txt")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-directory
@@ -7576,19 +7571,7 @@ may optionally be provided to further inform the peak-calling process.")
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; python2 only
- #:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- ;; When setuptools is used a ".egg" archive is generated and
- ;; installed. This makes it hard to actually run PePr. This issue
- ;; has been reported upstream:
- ;; https://github.com/shawnzhangyx/PePr/issues/9
- (add-after 'unpack 'disable-egg-generation
- (lambda _
- (substitute* "setup.py"
- (("from setuptools import setup")
- "from distutils.core import setup"))
- #t)))))
+ #:tests? #f)) ; no tests included
(propagated-inputs
`(("python2-numpy" ,python2-numpy)
("python2-scipy" ,python2-scipy)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e447ef1603..b86f5efbfa 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -638,11 +638,6 @@ using a stylus.")
(base32
"0rz2pg04wnzjjm2f5a8ik9v8s54mv4xrjhv5liqjijqv6awh12gl"))))
(build-system python-build-system)
- (arguments
- ;; Prevent creation of the egg. Without this flag, various artifacts
- ;; from the build inputs end up in the final python3 output. It also
- ;; works around https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
- `(#:configure-flags '("--single-version-externally-managed" "--root=/")))
(propagated-inputs
`(("python-pillow" ,python-pillow)))
(home-page "http://www.reportlab.com")
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f103706533..3fcd92dc83 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2800,12 +2800,6 @@ sources.")
(base32
"19nw3rn7awplcdrz63kg1njqwkbymfg9lwn7l2grhdyhyr2gaa8g"))))
(build-system python-build-system)
- (arguments
- `(;; With standard flags, the install phase attempts to create a zip'd
- ;; egg file, and fails with an error: 'ZIP does not support timestamps
- ;; before 1980'
- #:configure-flags '("--single-version-externally-managed"
- "--record=sphinx-rtd-theme.txt")))
(inputs
`(("python-docutils" ,python-docutils)
("python-sphinx" ,python-sphinx)))
@@ -3988,12 +3982,7 @@ Python's distutils.")
(arguments
;; incompatible with Python 3 (exception syntax)
`(#:python ,python-2
- #:tests? #f
- ;; With standard flags, the install phase attempts to create a zip'd
- ;; egg file, and fails with an error: 'ZIP does not support timestamps
- ;; before 1980'
- #:configure-flags '("--single-version-externally-managed"
- "--record=elib.txt")))
+ #:tests? #f))
(home-page "https://github.com/dieterv/elib.intl")
(synopsis "Enhanced internationalization for Python")
(description
@@ -4026,17 +4015,6 @@ services for your Python modules and applications.")
;; Note: setuptools used at runtime for pkg_resources
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before
- 'install 'disable-egg-compression
- (lambda _
- ;; Leave the .egg uncompressed since compressing it would
- ;; prevent the GC from identifying run-time dependencies.
- ;; See <http://bugs.gnu.org/20765>.
- (let ((port (open-file "setup.cfg" "a")))
- (display "\n[easy_install]\nzip_ok = 0\n"
- port)
- (close-port port)
- #t)))
(add-after
'install 'check-installed
(lambda _
@@ -6520,15 +6498,7 @@ a hash value.")
(substitute* "libarchive/ffi.py"
(("find_library\\('archive'\\)")
(string-append "'" libarchive
- "/lib/libarchive.so'"))))
-
- ;; Do not make a compressed egg (see
- ;; <http://bugs.gnu.org/20765>).
- (let ((port (open-file "setup.cfg" "a")))
- (display "\n[easy_install]\nzip_ok = 0\n"
- port)
- (close-port port)
- #t))))))
+ "/lib/libarchive.so'")))))))))
(inputs
`(("libarchive" ,libarchive)))
(home-page "https://github.com/Changaco/python-libarchive-c")
@@ -9454,9 +9424,6 @@ CloudFront content delivery network.")
`(;; Tests fail with "ValueError: _type_ 'v' not supported" on Python 3,
;; and on Python 2 they need the dl module deprecated since Python 2.6.
#:tests? #f
- ;; Prevent creation of the egg. This works around
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
- #:configure-flags '("--single-version-externally-managed" "--root=/")
;; Hard-code the path to pkg-config.
#:phases
(modify-phases %standard-phases
@@ -10979,10 +10946,7 @@ failures.")
"06032agzhw1i9d9qlhfblnl3dw5hcyxhagn7b120zhrszbjzfbh3"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Fails with recent pytest and pep8. See upstream issues #8 and #12.
- ;; Prevent creation of the egg. This works around
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
- #:configure-flags '("--single-version-externally-managed" "--root=/")))
+ `(#:tests? #f)) ; Fails with recent pytest and pep8. See upstream issues #8 and #12.
(native-inputs
`(("python-pytest" ,python-pytest)))
(propagated-inputs
@@ -11007,10 +10971,7 @@ failures.")
"0flag3n33kbhyjrhzmq990rvg4yb8hhhl0i48q9hw0ll89jp28lw"))))
(build-system python-build-system)
(arguments
- `(;; Prevent creation of the egg. This works around
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
- #:configure-flags '("--single-version-externally-managed" "--root=/")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'check)
(add-after 'install 'check
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 950c3ec64f..cca08d26a8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1394,13 +1394,7 @@ and fast file reading.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'check (lambda _ (zero? (system* "nosetests" "-v"))))
- (add-after 'unpack 'prevent-generation-of-egg-archive
- (lambda _
- (substitute* "setup.py"
- (("from setuptools import setup")
- "from distutils.core import setup"))
- #t)))))
+ (replace 'check (lambda _ (zero? (system* "nosetests" "-v")))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 608fd6a080..607fa33b27 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -437,15 +437,6 @@ security, and applying best practice development processes.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'install 'disable-egg-compression
- (lambda _
- ;; Do not compress the egg.
- ;; See <http://bugs.gnu.org/20765>.
- (let ((port (open-file "setup.cfg" "a")))
- (display "\n[easy_install]\nzip_ok = 0\n"
- port)
- (close-port port)
- #t)))
(add-after 'install 'docs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index e6fbf6e005..fe079fb104 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -208,11 +208,7 @@ networks.")
;; After all the patching we run the tests after installing.
;; This is also a known issue:
;; https://github.com/micahflee/onionshare/issues/284
- (lambda _ (zero? (system* "nosetests" "test")))))
- ;; can't compress the egg because it expects to find all the resources
- ;; inside the egg as though it were a folder.
- #:configure-flags '("--single-version-externally-managed" "--root=/")
- ))
+ (lambda _ (zero? (system* "nosetests" "test")))))))
(native-inputs
`(("python-nose" ,python-nose)))
(inputs