summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-04 22:13:22 -0500
committerKei Kebreau <kei@openmailbox.org>2017-03-04 22:24:17 -0500
commit9f86202ba1fda3f22ff5044420658e16b18edfd2 (patch)
tree0d7748b35d85512c58406842c719c1b8444127fa /gnu/packages
parent07302d1ab4fae67117476a51a1031de02b05b519 (diff)
downloadguix-patches-9f86202ba1fda3f22ff5044420658e16b18edfd2.tar
guix-patches-9f86202ba1fda3f22ff5044420658e16b18edfd2.tar.gz
gnu: starfighter: Update to 1.7.
* gnu/packages/games.scm (starfighter): Update to 1.7. [arguments]: Remove obsolete make flags. Re-enable configure and test phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7333cfca00..550652eefd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2617,7 +2617,7 @@ tactics.")
(define-public starfighter
(package
(name "starfighter")
- (version "1.6")
+ (version "1.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2626,18 +2626,8 @@ tactics.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "1qb5nk0b3d0ia5zszmg4a3ydf4fiy39fmymb66vwkqn4djajdhzq"))))
+ "1646hpjq8bz2fkfkja1dah511hn7zd2r7da4w9c9blhad3p5732v"))))
(build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no check target
- #:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (list (string-append "PREFIX=" out)
- (string-append "BINDIR=" out "/bin/")))
- #:phases
- (modify-phases %standard-phases
- ;; no configure script
- (delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs