summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:26 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:51 +0200
commit778ae273e91f67022640dfa3aa951467558e814b (patch)
tree9a93c9d2cc16ce70d430eb4885c1aec8ebdb3edf /gnu/packages
parent68a33f3d19dd8bcfc567cb5e7fe11c9664e81e14 (diff)
downloadguix-patches-778ae273e91f67022640dfa3aa951467558e814b.tar
guix-patches-778ae273e91f67022640dfa3aa951467558e814b.tar.gz
gnu: Add python-pytest-datadir.
* gnu/packages/check.scm (python-pytest-datadir): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d4820d911d..14ffee25a0 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2918,3 +2919,26 @@ to mark some tests as dependent from other tests. These tests will then be
skipped if any of the dependencies did fail or has been skipped.")
(license license:asl2.0)))
+(define-public python-pytest-datadir
+ (package
+ (name "python-pytest-datadir")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-datadir" version))
+ (sha256
+ (base32
+ "066bg6wlzgq2pqnjp73dfrcmk8951xw3aqcxa3p1axgqimrixbyk"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-wheel" ,python-wheel)))
+ (home-page "https://github.com/gabrielcnr/pytest-datadir")
+ (synopsis "Pytest plugin for manipulating test data directories and files")
+ (description
+ "This package provides a Pytest plugin for manipulating test data
+directories and files.")
+ (license license:expat)))