summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorrennes <rennes@openmailbox.org>2017-02-17 19:16:36 -0600
committerLeo Famulari <leo@famulari.name>2017-03-04 23:15:01 -0500
commit40c611a41df35877c91a6b1ef66bdc84e6355ec7 (patch)
treebe735f652b6bcb67e927df7b7e7ad1e1018a6bcd /gnu/packages
parent9f86202ba1fda3f22ff5044420658e16b18edfd2 (diff)
downloadguix-patches-40c611a41df35877c91a6b1ef66bdc84e6355ec7.tar
guix-patches-40c611a41df35877c91a6b1ef66bdc84e6355ec7.tar.gz
gnu: wxwidgets: Fix for Filezilla client.
* gnu/packages/patches/wxwidgets-fix-windowGTK.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/wxwidgets-fix-windowGTK.patch18
-rw-r--r--gnu/packages/wxwidgets.scm5
2 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/patches/wxwidgets-fix-windowGTK.patch b/gnu/packages/patches/wxwidgets-fix-windowGTK.patch
new file mode 100644
index 0000000000..1255835d01
--- /dev/null
+++ b/gnu/packages/patches/wxwidgets-fix-windowGTK.patch
@@ -0,0 +1,18 @@
+This patch allow Filezilla client to resize window.
+The patch was adapted from upstream source repository:
+'<http://trac.wxwidgets.org/changeset/4793e5b0a4e189e492287305859b278fed780080/git-wxWidgets>'
+
+--- a/src/gtk/toplevel.cpp 2014-10-06 16:33:44.000000000 -0500
++++ b/src/gtk/toplevel.cpp 2017-02-16 21:33:27.779907810 -0600
+@@ -1216,8 +1216,9 @@
+ int hints_mask = GDK_HINT_MIN_SIZE | GDK_HINT_MAX_SIZE;
+ hints.min_width = 1;
+ hints.min_height = 1;
+- hints.max_width = INT_MAX;
+- hints.max_height = INT_MAX;
++ // using INT_MAX for size will lead to integer overflow with HiDPI scaling
++ hints.max_width = INT_MAX / 16;
++ hints.max_height = INT_MAX / 16;
+ const int decorSize_x = m_decorSize.left + m_decorSize.right;
+ const int decorSize_y = m_decorSize.top + m_decorSize.bottom;
+ if (minSize.x > decorSize_x)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 5285037ffe..52fa8184dd 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,9 @@
"releases/download/v" version
"/wxWidgets-" version ".tar.bz2"))
(sha256
- (base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))))
+ (base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))
+ (patches (search-patches
+ "wxwidgets-fix-windowGTK.patch"))))
(build-system glib-or-gtk-build-system)
(inputs
`(("glu" ,glu)