summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-15 10:45:17 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-15 10:46:43 +0100
commit60357f99c4ca24e50c94c70406e2e015c369d63e (patch)
treee00def8498f414e46c013f99fb9446425d52eb68 /gnu/packages
parent0b0e11a9d8c366ebb345eb59209a7fbf5a1db397 (diff)
downloadguix-patches-60357f99c4ca24e50c94c70406e2e015c369d63e.tar
guix-patches-60357f99c4ca24e50c94c70406e2e015c369d63e.tar.gz
gnu: Add python-netifaces.
* gnu/packages/python.scm (python-netifaces, python2-netifaces): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4bc023a9f6..984ec9a458 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3178,3 +3178,32 @@ another XPath engine to find the matching elements in an XML or HTML document.")
(define-public python2-cssselect
(package-with-python2 python-cssselect))
+
+(define-public python-netifaces
+ (package
+ (name "python-netifaces")
+ (version "0.10.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/netifaces/netifaces-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1plw237a4zib4z8s62g0mrs8gm3kjfrp5sxh6bbk9nl3rdls2mln"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page
+ "https://bitbucket.org/al45tair/netifaces")
+ (synopsis
+ "Python module for portable network interface information")
+ (description
+ "Netifaces is a Python module providing information on network
+interfaces in an easy and portable manner.")
+ (license license:expat)))
+
+(define-public python2-netifaces
+ (package-with-python2 python-netifaces))