summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-13 11:24:00 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-13 17:28:19 +0100
commit57a516d3ec6e6166490ce2892b0e767c5199d060 (patch)
tree7051610a90fc1064bc68bbf8145a6bab3dfb2341 /gnu/packages
parent5deea4fcc9ec25816ff869ae840ed225a93b1c21 (diff)
downloadguix-patches-57a516d3ec6e6166490ce2892b0e767c5199d060.tar
guix-patches-57a516d3ec6e6166490ce2892b0e767c5199d060.tar.gz
gnu: Add acpid.
* gnu/packages/linux.scm (acpid): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index de3e6cb496..99adda92c9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1837,3 +1837,24 @@ thanks to the use of namespaces.")
is for enabling irq-unmasking and IDE multiplemode.")
(license (bsd-style "file://LICENSE.TXT"))))
+(define-public acpid
+ (package
+ (name "acpid")
+ (version "2.0.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/acpid2/acpid-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1vl7c6vc724v4jwki17czgj6lnrknnj1a6llm8gkl32i2gnam5j3"))))
+ (build-system gnu-build-system)
+ (home-page "http://sourceforge.net/projects/acpid2/")
+ (synopsis "Daemon for delivering ACPI events to user-space programs")
+ (description
+ "acpid is designed to notify user-space programs of Advanced
+Configuration and Power Interface (ACPI) events. acpid should be started
+during the system boot, and will run as a background process. When an ACPI
+event is received from the kernel, acpid will examine the list of rules
+specified in /etc/acpi/events and execute the rules that match the event.")
+ (license gpl2+)))