summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-05 16:52:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-05 21:17:59 +0100
commit38e4477a8b2b030b3eb92b3407b79dcec5d8e4c0 (patch)
treec1e09cd8b1c4bd508e9b847dff4d5fea4b4841e1 /gnu/packages
parent3cb1548f91f983e75ddd41ffed2a8090734c6352 (diff)
downloadguix-patches-38e4477a8b2b030b3eb92b3407b79dcec5d8e4c0.tar
guix-patches-38e4477a8b2b030b3eb92b3407b79dcec5d8e4c0.tar.gz
gnu: r-httpuv: Update to 1.6.4.
* gnu/packages/cran.scm (r-httpuv): Update to 1.6.4. * gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch: Adjust to version 1.6.4.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm4
-rw-r--r--gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch34
2 files changed, 26 insertions, 12 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 590e7008ee..a70684b9c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1556,13 +1556,13 @@ Zucchini.")
(define-public r-httpuv
(package
(name "r-httpuv")
- (version "1.6.3")
+ (version "1.6.4")
(source (origin
(method url-fetch)
(uri (cran-uri "httpuv" version))
(sha256
(base32
- "0xh8y05k4jxdwp9xh4x478y3scnv80q05l9gxk2ni6f0dk43iqxz"))
+ "0nx6fakpj9qh6izs6n26y3i8v4dm16h61ijw3gymsbif34fx532f"))
;; Unvendor bundled libraries. As of 1.5.4 the vendored libuv
;; only contains fixes for building on Solaris.
(patches (search-patches "r-httpuv-1.5.5-unvendor-libuv.patch"))
diff --git a/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch b/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
index 0947718059..30c6425477 100644
--- a/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
+++ b/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
@@ -20,7 +20,7 @@ Removes references to bundled libuv.
# To avoid spurious warnings from `R CMD check --as-cran`, about compiler
# warning flags like -Werror.
-@@ -43,35 +43,5 @@
+@@ -43,49 +43,5 @@
# PKG_CPPFLAGS += -D_GLIBCXX_ASSERTIONS
@@ -32,10 +32,18 @@ Removes references to bundled libuv.
-libuv/m4/lt~obsolete.m4: libuv/m4/lt_obsolete.m4
- cp -p -f libuv/m4/lt_obsolete.m4 libuv/m4/lt~obsolete.m4
-
--# Run ./configure. We need to touch various autotools-related files to avoid
--# it trying to run autotools programs again. We also need to make sure
--# configure is executable, because on some platforms, calling unzip() in R
--# does not preserve the executable bit.
+-# Run ./configure to create the Makefile.
+-#
+-# On systems that do _not_ have automake installed, we need to make sure that
+-# configure does not try to run automake, because it will fail. To do that, we
+-# we need to touch various autotools-related files so it doesn't try to run
+-# autotools programs again. We also need to make sure configure is executable,
+-# because on some platforms, calling unzip() in R does not preserve the
+-# executable bit.
+-#
+-# If the system does have automake, then we'll run autogen.sh before configure,
+-# as per the official build instructions for libuv. autogen.sh will in turn run
+-# aclocal, autoconf, and automake.
-#
-# It's VERY IMPORTANT that mtime(aclocal.m4) <= mtime(configure), and also
-# mtime(aclocal.m4) <= mtime(Makefile.in). On some platforms, passing multiple
@@ -45,11 +53,17 @@ Removes references to bundled libuv.
-# use "-r aclocal.m4" to ensure that all three files are guaranteed to have
-# precisely the same timestamp value.
-libuv/Makefile: libuv/m4/lt~obsolete.m4
-- (cd libuv \
-- && touch aclocal.m4 \
-- && touch -r aclocal.m4 configure Makefile.in \
-- && chmod +x configure \
-- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFIGURE_FLAGS))
+- cd libuv; \
+- if ! command -v automake >/dev/null 2>&1 ; then \
+- echo "automake not found. Touching files so configure will not try to run automake."; \
+- touch aclocal.m4; \
+- touch -r aclocal.m4 configure Makefile.in; \
+- else \
+- echo "automake found. Running autogen.sh."; \
+- sh autogen.sh; \
+- fi; \
+- chmod +x configure; \
+- CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFIGURE_FLAGS)
-
-libuv/.libs/libuv.a: libuv/Makefile
- $(MAKE) --directory=libuv \