summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-27 12:07:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-01 22:40:04 +0200
commitdc827867be9496dd7071b76c0629da2ddbb82696 (patch)
tree9e88f3ab775d34dab46e9ff80641862938eea890 /gnu/packages
parentf27c6c16be002d3c132cfc09c5911384be853f27 (diff)
downloadguix-patches-dc827867be9496dd7071b76c0629da2ddbb82696.tar
guix-patches-dc827867be9496dd7071b76c0629da2ddbb82696.tar.gz
gnu: Add python-boolean.py.
* gnu/packages/python-xyz.scm (python-boolean.py): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bd218b797..adc6fc08bf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -387,6 +387,32 @@ certificate returned by the server to which a connection has been established,
and verifies that it matches the intended target hostname.")
(license license:psfl)))
+(define-public python-boolean.py
+ (package
+ (name "python-boolean.py")
+ (version "3.6")
+ (source
+ (origin
+ ;; There's no source tarball on PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bastikr/boolean.py")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wc89y73va58cj7dsx6c199zpxsy9q53dsffsdj6zmc90inqz6qs"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/bastikr/boolean.py")
+ (synopsis "Boolean algebra in one Python module")
+ (description
+ "This is a small Python library that implements boolean algebra.
+It defines two base elements, @code{TRUE} and @code{FALSE}, and a
+@code{Symbol} class that can take on one of these two values. Calculations
+are done only in terms of @code{AND}, @code{OR}, and @code{NOT}---other
+compositions like @code{XOR} and @code{NAND} are emulated on top of them.
+Expressions are constructed from parsed strings or directly in Python.")
+ (license license:bsd-2)))
+
(define-public python-hdf4
(package
(name "python-hdf4")