summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-27 12:08:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-01 22:40:05 +0200
commitd6803445eeff619214cc9fcf99af79975c36f740 (patch)
treea12fa6885987bb34406345dbee91aa0e928d86c4 /gnu/packages
parentdc827867be9496dd7071b76c0629da2ddbb82696 (diff)
downloadguix-patches-d6803445eeff619214cc9fcf99af79975c36f740.tar
guix-patches-d6803445eeff619214cc9fcf99af79975c36f740.tar.gz
gnu: Add python-license-expression.
* gnu/packages/python-xyz.scm (python-license-expression): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index adc6fc08bf..413d68c258 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -609,6 +609,29 @@ to users of that module.")
(define-public python2-netcdf4
(package-with-python2 python-netcdf4))
+(define-public python-license-expression
+ (package
+ (name "python-license-expression")
+ (version "0.999")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "license-expression" version))
+ (sha256
+ (base32 "08ppb0bxbrsxazy88sgpl9yffvdsabw6dkk1nc332wcz2mphwwyf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-boolean.py" ,python-boolean.py)))
+ (home-page "https://github.com/nexB/license-expression")
+ (synopsis "Apply boolean logic to license expressions")
+ (description
+ "This Python module defines a tiny language to evaluate and compare
+license expressions using boolean logic. Logical combinations of licenses can
+be tested for equality, containment, and equivalence. They can be normalised
+and simplified. It supports SPDX license expressions as well as other naming
+conventions and aliases in the same expression.")
+ (license license:gpl2+)))
+
(define-public python-lockfile
(package
(name "python-lockfile")