summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-13 00:23:25 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2019-03-16 13:31:39 +0300
commitd82bd2034884c5037065c48d5eefe0acd2768e30 (patch)
tree65ef620e910cd2b82434fe90e5c6a2f20c9c18ed /gnu/packages
parent4161deb4549c39b7d4801cc8aa63c365d19fc649 (diff)
downloadguix-patches-d82bd2034884c5037065c48d5eefe0acd2768e30.tar
guix-patches-d82bd2034884c5037065c48d5eefe0acd2768e30.tar.gz
gnu: Add emacs-eshell-z.
Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5936a2d23..28f86fd709 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11176,6 +11176,29 @@ visiting the bookmark, a new @code{eshell} session will be opened in the
appropriate directory if no @code{eshell} session is active.")
(license license:gpl3+)))
+(define-public emacs-eshell-z
+ (package
+ (name "emacs-eshell-z")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-z")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1aac4m814jgxwpz7lbyx5r4z5dmawp4sk7pwbx0zqpnbcsaq5wwc"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/xuchunyang/eshell-z")
+ (synopsis "Quick navigation to frequently visited directories")
+ (description
+ "This package is a port of @code{z}, and keeps track of visited directories
+and commands invoked within them in order to enable navigation via input of
+matching regexps.")
+ (license license:gpl3+)))
+
(define-public emacs-esh-autosuggest
(package
(name "emacs-esh-autosuggest")