summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-08 22:40:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:25 -0500
commitd102bd7316bc2f8fe973987eac13975ac429d50f (patch)
treead88911de21eb67580a71de354543de1eda124b5 /gnu/packages
parent169354db3832b5ed1b2d256b975dc786d35ab066 (diff)
downloadguix-patches-d102bd7316bc2f8fe973987eac13975ac429d50f.tar
guix-patches-d102bd7316bc2f8fe973987eac13975ac429d50f.tar.gz
gnu: abseil-cpp: Remove googletest patch.
* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/cpp.scm (abseil-cpp)[source]: Remove patch. Co-authored-by: Greg Hogan <code@greghogan.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm5
-rw-r--r--gnu/packages/patches/abseil-cpp-fix-gtest.patch16
2 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index fe49d1f1b3..77ed9e0c97 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -778,11 +778,8 @@ point and then, after each tween step, plugging back the result.")
(sha256
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
- ;; Remove after next googletest release and update.
(patches
- (search-patches
- "abseil-cpp-fix-gtest.patch"
- "abseil-cpp-fix-strerror_test.patch"))))
+ (search-patches "abseil-cpp-fix-strerror_test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
diff --git a/gnu/packages/patches/abseil-cpp-fix-gtest.patch b/gnu/packages/patches/abseil-cpp-fix-gtest.patch
deleted file mode 100644
index 38971448f3..0000000000
--- a/gnu/packages/patches/abseil-cpp-fix-gtest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
-in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
-a googletest release.
-
---- a/absl/container/internal/unordered_map_modifiers_test.h
-+++ b/absl/container/internal/unordered_map_modifiers_test.h
-@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
- }
- };
-
-+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
- GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
-+#endif
-
- TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
-