summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-11-02 14:57:07 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-11-03 15:43:18 -0700
commit75b538daf46a8c983c9193166d86e7e8ea84b69d (patch)
tree56e7556acf4d49fc9321bde8377c5692d38c200a /gnu/packages
parentbbac6c52480dc8572b74eb6235bdf55c1cf9842b (diff)
downloadguix-patches-75b538daf46a8c983c9193166d86e7e8ea84b69d.tar
guix-patches-75b538daf46a8c983c9193166d86e7e8ea84b69d.tar.gz
gnu: Fix various synopsis and description issues.
* gnu/packages/admin.scm (greetd-pam-mount)[synopsis]: Base synopsis on pam-mount synopsis. [description]: Use two spaces consistently. (greetd)[synopsis]: Begin sentence with upper-case. * gnu/packages/xdisorg.scm (wlsunset)[description]: Fix spelling and case of wlsunsest. * gnu/packages/mail.scm (libpst): Add synopsis. * gnu/packages/networking.scm (librecast)[synopsis]: Update synopsis. (lcrq)[description]: Use two spaces after sentences.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm6
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/xdisorg.scm2
4 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9cf64c3a49..2fbab6d88c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5214,7 +5214,7 @@ it won't take longer to install 15 machines than it would to install just 2.")
(native-inputs
`(("linux-pam" ,linux-pam)
("scdoc" ,scdoc)))
- (synopsis "minimal and flexible login manager daemon")
+ (synopsis "Minimal and flexible login manager daemon")
(description
"greetd is a minimal and flexible login manager daemon
that makes no assumptions about what you want to launch.
@@ -5242,7 +5242,7 @@ then it can be a greeter.")
"#define CONFIGFILE \"/etc/security/greetd_pam_mount.conf.xml\"\n")
(("pam_mount_config") "greetd_pam_mount_config")
(("pam_mount_system_authtok") "greetd_pam_mount_system_authtok"))))))))
- (synopsis "pam-mount specifically compiled for use with greetd")
+ (synopsis "PAM module to mount volumes for a user session (greetd variant)")
(description
"Pam-mount is a PAM module that can mount volumes when a user logs in.
It supports mounting local filesystems of any kind the normal mount utility
@@ -5250,7 +5250,7 @@ supports. It can also mount encrypted LUKS volumes using the password
supplied by the user when logging in.
This package inherits pam-mount in the way that it is compiled specifically
-for use with greetd daemon. It uses different configuration location and
+for use with greetd daemon. It uses different configuration location and
name space for storing data in PAM.
greetd-pam-mount is used in configuration of greetd to provide
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 154ffb6640..e09852abb6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4533,7 +4533,7 @@ undelete email messages from Outlook Express .dbx files.")
(native-inputs
(list pkg-config))
(home-page "https://www.five-ten-sg.com/libpst/")
- (synopsis "")
+ (synopsis "Tools to process Outlook email archives")
(description "The Libpst utilities include @code{readpst} which can
convert email messages to both mbox and MH mailbox formats, @code{pst2ldif}
which can convert the contacts to @code{.ldif} format for import into LDAP
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8b5b0c9f2a..3a0a83837a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -273,7 +273,7 @@ protocols.")
(description
"C library implementation of RaptorQ Forward Error Correction for
Librecast. RFC6330 (IETF) describes the RaptorQ proposed standard, which LCRQ
-more-or-less follows. The primary focus has been on building a fast, simple
+more-or-less follows. The primary focus has been on building a fast, simple
and dependency-free FEC implementation for use with Librecast, and not on
strict standards compliance. The code does, however, fairly closely follow
the RFC.")
@@ -524,7 +524,7 @@ GLib-based library, libnice, as well as GStreamer elements to use it.")
(delete-file "./test/0000-0039.c")
(delete-file "./test/0000-0040.c"))))))
(inputs (list libsodium lcrq))
- (synopsis "librecast IPv6 multicast library")
+ (synopsis "IPv6 multicast library")
(description "Librecast is a C library which supports IPv6 multicast
networking.")
(home-page "https://librecast.net/librecast.html")
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 0bd0317527..8e70050850 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3163,7 +3163,7 @@ MouseKeys-acceleration management.")
(synopsis "Day/night gamma adjustments for Wayland compositors")
(home-page "https://sr.ht/~kennylevinsen/wlsunset/")
(description
- "wlunset adjusts gamma based on day-night cycles on Wayland compositors
+ "Wlsunset adjusts gamma based on day-night cycles on Wayland compositors
that support @samp{wlr-gamma-control-unstable-v1}. It is also known as a blue
light filter or night light.")
(license license:expat)))