summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-01 09:11:12 +0000
committerKei Kebreau <kkebreau@posteo.net>2017-09-29 18:00:11 -0400
commit6e79949f46caf8a4e289163bca839ed9127953b5 (patch)
tree92eb747441a8f1fa904ca2aa32f0f4e702a4552b /gnu/packages
parent16818c4856b8fe0b57054b60d5c33ede7fe6e8b5 (diff)
downloadguix-patches-6e79949f46caf8a4e289163bca839ed9127953b5.tar
guix-patches-6e79949f46caf8a4e289163bca839ed9127953b5.tar.gz
gnu: Add xautomation.
* gnu/packages/xdisorg.scm (xautomation): New variable. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xdisorg.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index edb70a37a8..7ca4986a0e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -560,6 +560,41 @@ xedit, for example. The human factors crowd would agree it should make
things less distracting.")
(license license:public-domain)))
+(define-public xautomation
+ (package
+ (name "xautomation")
+ (version "1.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.hoopajoo.net/static/projects/"
+ "xautomation-" version ".tar.gz"))
+
+ (sha256
+ (base32
+ "03azv5wpg65h40ip2kk1kdh58vix4vy1r9bihgsq59jx2rhjr3zf"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpng" ,libpng)
+ ("libx11" ,libx11)
+ ("libxi" ,libxi)
+ ("libxtst" ,libxtst)))
+ (native-inputs
+ `(("inputproto" ,inputproto)
+ ("xextproto" ,xextproto)
+ ("xproto" ,xproto)))
+ (synopsis "Tools to automate tasks in X such as detecting on screen images")
+ (description
+ "Xautomation can control X from the command line for scripts, and
+do visual scraping to find things on the screen. The control interface
+allows mouse movement, clicking, button up/down, key up/down, etc, and
+uses the XTest extension so you don't have the annoying problems that
+xse has when apps ignore sent events. The visgrep program can find
+images inside of images and reports the coordinates, allowing progams
+to find buttons, etc, on the screen to click on.")
+ (home-page "https://www.hoopajoo.net/projects/xautomation.html")
+ (license license:gpl2+)))
+
(define-public xlockmore
(package
(name "xlockmore")