summaryrefslogtreecommitdiff
path: root/gnu/packages/yubico.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-26 07:33:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-10-26 10:45:49 +0100
commitf9c339603d751783e40ce99c9f09639f168ba731 (patch)
tree7575db33bb8feff12032e6202d2e4ea65d97561d /gnu/packages/yubico.scm
parent7a6213cbd7427bdac28e7fef47c6a0c224175940 (diff)
downloadguix-patches-f9c339603d751783e40ce99c9f09639f168ba731.tar
guix-patches-f9c339603d751783e40ce99c9f09639f168ba731.tar.gz
gnu: yubico.scm: Rename to security-token.scm.
* gnu/packages/yubico.scm: Delete file. * gnu/packages/security-token.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
Diffstat (limited to 'gnu/packages/yubico.scm')
-rw-r--r--gnu/packages/yubico.scm77
1 files changed, 0 insertions, 77 deletions
diff --git a/gnu/packages/yubico.scm b/gnu/packages/yubico.scm
deleted file mode 100644
index 469d93d0dc..0000000000
--- a/gnu/packages/yubico.scm
+++ /dev/null
@@ -1,77 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages yubico)
- #:use-module (gnu packages)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages man)
- #:use-module (gnu packages curl))
-
-(define-public libyubikey
- (package
- (name "libyubikey")
- (version "1.13")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://developers.yubico.com/yubico-c/Releases/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "009l3k2zyn06dbrlja2d4p2vfnzjhlcqxi88v02mlrnb17mx1v84"))))
- (build-system gnu-build-system)
- (synopsis "Development kit for the YubiKey authentication device")
- (description
- "This package contains a C library and command-line tools that make up
-the low-level development kit for the Yubico YubiKey authentication device.")
- (home-page "https://developers.yubico.com/yubico-c/")
- (license bsd-2)))
-
-(define-public ykclient
- (package
- (name "ykclient")
- (version "2.15")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://developers.yubico.com/yubico-c-client/Releases/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "05jhx9waj3pl120ddnwap1v3bjrnbfhvf3lxs2xmhpcmwzpwsqgl"))))
- (build-system gnu-build-system)
-
- ;; There's just one test, and it requires network access to access
- ;; yubico.com, so skip it.
- (arguments '(#:tests? #f))
-
- (native-inputs `(("pkg-config" ,pkg-config)
- ("help2man" ,help2man)))
- (inputs `(("curl" ,curl)))
- (synopsis "C library to validate one-time-password YubiKeys")
- (description
- "YubiKey C Client Library (libykclient) is a C library used to validate a
-one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
-website for more information about Yubico and the YubiKey.")
- (home-page "https://developers.yubico.com/yubico-c-client/")
- (license bsd-2)))