summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-05-13 08:43:29 -0700
committerChristopher Baines <mail@cbaines.net>2024-05-14 12:05:25 +0100
commit61140300c20609f540029e30b72b7bf466f259cd (patch)
tree35a3e5672507a0546b04eda0707ca2f6a9af06f2 /gnu/packages/xorg.scm
parent49ec9f4ba32657528e0924df402f6aa6e5509fd5 (diff)
downloadguix-patches-61140300c20609f540029e30b72b7bf466f259cd.tar
guix-patches-61140300c20609f540029e30b72b7bf466f259cd.tar.gz
gnu: xpra: Update to 6.0.
* gnu/packages/xorg.scm (xpra): Update to 6.0. [inputs]: Add xxhash. [native-inputs]: Change python-cython to python-cython-3. * gnu/packages/patches/xpra-6.0-install_libs.patch: New file. * gnu/packages/patches/xpra-6.0-systemd-run.patch: New file. * gnu/packages/patches/xpra-5.0-install_libs.patch: Removed. * gnu/packages/patches/xpra-5.0-systemd-run.patch: Removed. * gnu/local.mk (dist_patch_DATA): Update accordingly Change-Id: Ic8ec98296220aebabb3d94951e11a3c957a8fcbc Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 74059a2691..1f1fe4d7c6 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages cups)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages emacs)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
@@ -6157,16 +6158,16 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "5.0.8")
+ (version "6.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.xpra.org/src/xpra-"
version ".tar.xz"))
(sha256
- (base32 "0ml9nv6gwrqgyrn3hp5kkxsbdl5fpz5w8vjsvn0qfdsgbvq617wy"))
- (patches (search-patches "xpra-5.0-systemd-run.patch"
- "xpra-5.0-install_libs.patch"))))
+ (base32 "1dh89k2whvim4lgnryr9hisdq2zzcc5md9c3vm49y6jsp4j77glq"))
+ (patches (search-patches "xpra-6.0-systemd-run.patch"
+ "xpra-6.0-install_libs.patch"))))
(build-system python-build-system)
(inputs
(list bash-minimal ; for wrap-program
@@ -6192,6 +6193,7 @@ basic eye-candy effects.")
xf86-video-dummy
xf86-input-mouse
xf86-input-keyboard
+ xxhash
python-pillow
;; Optional dependencies.
libx264
@@ -6207,7 +6209,7 @@ basic eye-candy effects.")
python-lz4 ; Faster compression than zlib.
python-netifaces
python-pycups))
- (native-inputs (list pkg-config pandoc python-cython))
+ (native-inputs (list pkg-config pandoc python-cython-3))
(arguments
(list
#:configure-flags #~(list "--without-Xdummy"