summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-08-26 17:05:56 -0400
committerMark H Weaver <mhw@netris.org>2020-08-27 00:13:38 -0400
commit6e7bede9bed8280fe0399aa1cae7e58bf1fdc6b2 (patch)
tree110f0e08d7021359a16a80323edb59cbd6e00703 /gnu/packages/xorg.scm
parent2ab8e6067c56165304bd7f119a179ea509676020 (diff)
downloadguix-patches-6e7bede9bed8280fe0399aa1cae7e58bf1fdc6b2.tar
guix-patches-6e7bede9bed8280fe0399aa1cae7e58bf1fdc6b2.tar.gz
gnu: xorg-server: Update replacement to 1.20.9 [security-fixes].
Includes fixes for CVE-2020-1436, CVE-2020-14345, CVE-2020-14346, and CVE-2020-14361. * gnu/packages/xorg.scm (xorg-server/fixed): Update to 1.20.9. * gnu/packages/patches/xorg-server-CVE-2020-14347.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index bb49d40fb6..b3aa7e7192 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5447,15 +5447,18 @@ communicates with the user via graphical controls such as buttons and
draggable titlebars and borders.")
(license license:x11)))
-(define xorg-server/fixed ; Fixes CVE-2020-14347
+(define xorg-server/fixed ; security fixes
(package
(inherit xorg-server)
+ (version "1.20.9")
(source
(origin
(inherit (package-source xorg-server))
- (patches
- (append (origin-patches (package-source xorg-server))
- (search-patches "xorg-server-CVE-2020-14347.patch")))))))
+ (uri (string-append "mirror://xorg/individual/xserver/"
+ "xorg-server-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0w9mrnffvjgmwi50kln15i8rpdskxv97r78l75wlcmg4vzhg46g2"))))))
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?