summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-05-02 16:57:52 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-02 23:41:14 +0200
commit2f3108ad036d5d59d0c8247703ba22adb57638e5 (patch)
tree185532b3425ea6e04f51d99ef8964e6ce07801ce /gnu/packages/xorg.scm
parentdcb95c1fc936d74dfdf84b7e59eff66cb99c5a63 (diff)
downloadguix-patches-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar
guix-patches-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar.gz
gnu: Avoid circular dependencies by Perl license.
* guix/licenses.scm (perl-license): New variable. * gnu/packages/bioinformatics.scm: Change (package-license perl) to perl-license. * gnu/packages/compression.scm: Same. * gnu/packages/databases.scm: Same. * gnu/packages/gd.scm: Same. * gnu/packages/language.scm: Same. * gnu/packages/libevent.scm: Same. * gnu/packages/mail.scm: Same. * gnu/packages/messaging.scm: Same. * gnu/packages/ncurses.scm: Same. * gnu/packages/networking.scm: Same. * gnu/packages/photo.scm: Same. * gnu/packages/tcl.scm: Same. * gnu/packages/tex.scm: Same. * gnu/packages/tls.scm: Same. * gnu/packages/web.scm: Same. * gnu/packages/wm.scm: Same. * gnu/packages/xml.scm: Same. * gnu/packages/xorg.scm: Same. * gnu/packages/zip.scm: Same. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3c9195b1bf..0bc38692e6 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5720,7 +5720,7 @@ programs that cannot use the window system directly.")
"These bindings wrap @code{libxcb} (a C library to speak with X11,
in many cases better than @code{Xlib}), and provides an object oriented
interface to its methods (using @code{Mouse}).")
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public perl-x11-protocol
(package
@@ -5748,7 +5748,7 @@ perl programs to display windows and graphics on X11 servers.")
;; distribution, has another, less restrictive copying policy, as do some
;; of the extension modules in the directory Protocol/Ext: see those files
;; for details)."
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public xcompmgr
(package